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ÖKONOMEETRIA ÜLESANDED
10. TUTVUMINE PROGRAMMIGA STATA

Ülesanne 10.1.  Autod									Video
Andmete ja tunnustega tutvumine. Kirjeldav statistika. Andmete filtreerimine.
Sagedusdiagramm. Histogramm. Korrelatsioonimaatriks. Hajumisdiagramm.
Lineaarse regressioonmudeli hindamine. Heteroskedastiivsuse ja jääkliikmete 
normaaljaotuse testimine. Mudelväärtuste leidmine.

Kasutame Stata näitefaili auto.dta, kus on andmed erinevate automudelite kohta. Stata inglisekeelne juhend, kus kasutatakse seda faili, asub aadressil https://www.stata.com/manuals13/gsw1.pdf
 
1) Stata näitefaili avamine
a) File->Example Datasets
b) Valida Example datasets installed with Stata
c) Valida auto.dta korral use
2) Tegevuste ja tulemuste salvestamiseks tuleb käivitada tegevuste logimine. 
File -> Log ->Begin
Logifailile tuleb anda nimi. Logifaili võib salvestada kahes formaadis:
	Formatted Log (*.smcl)	Sobib avamiseks programmis Stata.
	Log (*.log)			Sobib avamiseks muus programmis, näiteks Notepad, Word.
Salvestame vormindatud logi (Formatted Log).

3) Andmete kirjeldus.
Data > Describe data > Describe data in memory or in a file	In memory
Kuvatakse kõigi tunnuste nimetus, tüüp, kirjeldus.

4) Andmetabeliga tutvumine.
Data->Data Editor->Data editor (Browse)

5) Tunnuste haldur.
Data-> Variables Manager
Saab muuta tunnuste nimesid, kirjeldusi (Label). Kvalitatiivsete tunnuste korral saab vaadata ja omistada väärtustele vastavaid silte. 
Valida välja tunnus foreign ning akna paremas osas Value label juures valida Manage. Avaneb aken Value labels. Tutvuda sellega.

6) Kirjeldav statistika.
Statistics > Summaries, tables, and tests > Summary and descriptive statistics > Summary statistics
	Valida Submit	 See ei sulge akent ja peale summaarse statistikaga tutvumist saab samas aknas valida teisi võimalusi.

7) Detailsema kirjeldav statistika saamiseks tuleb aknas summarize märkida Display additional statistics
Vaadata detailsemat kirjeldavat statistikat hinna price kohta. 

8) Tunnuste struktuur, sisu, väärtuste vahemik ja muu info.
Data > Describe data > Describe data contents (codebook)
Tutvuda kõigi tunnustega.

9) Andmete filtreerimine teatud kriteeriumi järgi.
a) Filtreerida välja need autod, mille korral hind price on suurem kui 10000.
Data > Data Editor > Data editor (Browse) > Tools > Filter observations
Filtreerimiseks võib kasutada ka nuppu [image: ]

Reale Filter by expression	price > 10000		Apply filter
Filtri eemaldamiseks	 	Remove filter

10) Sagedustabelite moodustamine.
Fiktiivse tunnuse foreign alusel.
Statistics > Summaries, tables, and tests> Frequency tables > One-way table
Categorical variable 		foreign

11) Histogrammid. 
a) Uurida hinna price histogrammi
Graphics > Histogram
Variable 	price		
Märkida Y-teljel sagedused Frequency ja kuvada tulpade juures ka nende väärtused Add height labels to bars
Submit	Siis jääb aken avatuks ja saame veel histogramme kuvada.
Histogramm kuvatakse eraldi aknas Graph.
b) Uurida hinna price histogramme eraldi kodumaiste  ja välismaiste autode korral. Histogrammi käsuaknas leht By > Draw subgraphs for unique values of variables
Variables 		foreign
c) Vaadata sama histogrammi uuesti, aga kuvada mitte sagedused, vaid protsendid
Y-axis 	Percent

12) Korrelatsioonanalüüs.
a) Analüüsida korrelatsioonimaatriksit tunnuste mpg,  weight, length, turn ja displacement. vahel.
Statistics > Summaries, tables, and tests > Summary and descriptive statistics > Pairwise correlations
Korrelatsioonikordaja statistilise olulisuse märkimiseks Significance level for displaying with a star

b) Sama korrelatsioonimaatriksi analüüs eraldi kodumaiste ja välismaiste autode korral.
Lehel by/if/in 	valida Repeat command by groups ja valida 	foreign

13) Hajumisdiagramm tunnuste mpg ja weight vahel.
Graphics > Twoway graph (scatter, line, etc.).
Create	Basic plots, Scatter 
Y variable 	mpg		X variable 	weight

Panna tähele, et seos on mittelineaarne.

14) Lineaarse regressioonmudeli hindamine hariliku vähimruutude meetodil (OLS). Hinnata mudelit, kus läbisõit 1 galloniga sõltub auto kaalust ja sellest, kas on kodumaine või mitte. Kuna hajumisdiagramm näitas, et sõltuvus kaalust weight on mittelineaarne, lisada mudelisse ka selle ruutliige.


	
a) Kaalu weight ruut tuleb eelnevalt luua. Uute tunnuste loomine käib käsuga generate, millele järgneb uue tunnuse nimi ja see järel arvutusvalem. Käsuaknasse
generate wtsq = weight^2
Käsu aktiveerimiseks klaviatuurilt Enter.
b) Lineaarse regressioonmudeli hindamine.
Statistics > Linear models and related -> Linear regressioon
Valida välja sõltuv tunnus mpg ja sõltumatud tunnused weight wtsq foreign
 Tutvuda mudeli aruandega.

15) Heteroskedastiivsuse testimine. Erinevad testid peale regressioonmudeli hindamist leiab menüüst
Statistics > Linear models and related > Regression diagnostics > Specification tests, etc.

Heteroskedastiivsuse White’i testi leiab testide valikus Information matrix test (imtest).
Perform White’s original heteroskedasticity test

16) Jääkliikmete normaaljaotuse testimine. 
a) Selleks tuleb eelnevalt salvestada jääkliikmed:
Statistics> Postestimation > Predictions > Predictions and SE…		Launch

Uue tunnuse nimeks uhat	 ja valida Residuals
b) Normaaljaotuse testimine.
Statistics>Summaries, tables and tests > Distributional plots and tests
On erinevad testid. Sagedasti kasutatav on Shapiro-Wilk normality test. Nullhüpotees on, et väärtused alluvad normaaljaotusele.

17) Mudelväärtuste leidmine.
Statistics> Postestimation > Predictions > Predictions and SE…		Launch
Uue tunnuse nimeks mpg_hat	 ja valida Linear prediction (xb)
Andmebaasi lisatakse mpg mudelväärtused.

18) Mudelväärtuste ja tegelike väärtuste esitamine diagrammidel eraldi kodumaiste ja välismaiste mudelite jaoks
Graphics > Twoway graph (scatter, line, etc.).
Tuleb luua kaks graafikut ühes teljestikus: 
1 	Scatter		Y-teljel tegelikud väärtused mpg 	X-teljel weight
2 	Line		Y-teljel mudelväärtused mpg_hat	X-teljel weight, Sort on x variable
Graafikud eraldi kodumaiste ja välismaiste mudelite jaoks: lehel By	foreign

19) Logi lõpetamiseks 	File>Log>Close


Ülesanne 10.2  Eesti THHI							Fail EestiTHHI.dta, video
Ühikjuure testimine. Diferentside leidmine. Korrelogrammid. 
ARIMA modelleerimine. Prognoosimine. MAPE arvutamine.

Andmebaasis on Eesti tarbijahindade harmoneeritud indeks THHI (2005=100), kuud 2008. jaan – 2017 dets. Samad andmed, mis ülesandes 7.4, kus kasutasime programmi Gretl.

1) Avada andmefail	File>Open
2) Tutvuda andmetega. Panna tähele, mis formaadis on antud tunnus month.
3) Aegridade korral tuleb deklareerida, milline tunnus vastab ajale.
Statistics > Time series > Setup and utilities > Declare dataset to be time-series data
Time variable: month
4) Tutvuda aegrea diagrammiga. 
Graphics > Time-series graphs > Line plots
Luua graafik Plot, kus Y variable on THHI. Panna tähele, et aegrida on muutuva trendiga: on periood, kus trend puudub.

5) Ühikjuure testimine Dickey-Fuller testiga.
Statistics > Time series > Tests > Augmented Dickey-Fuller unit root test

[bookmark: _Hlk153467839]Vaikimisi kasutatakse konstandiga, ilma trendita mudelit.

Suppress constant term in regression	ilma konstandita
Icnlude trend term in regression		trendi ja konstandiga
Include drift term in regression	Kasutatakse konstandiga mudelit (mis tekitab triivi), aga teststatistik leitakse standardsest t-jaotusest. Pole eriti otstarbekas.
Display regression table		Kuvatakse ADF regressioonanalüüsi tulemus. Vajalik, et otsustada, millise kujuga võrrand sobib.

Lagged differences		Viitaegade arv. Sobiva viitaegade arvu leidmiseks võetakse ette mingi viitaegade arv ning siis hakatakse seda vähendama kuni kõik viitajad on statistiliselt olulised.

a) Viia läbi DF test, kasutada konstandi ja trendiga mudelit. Viitaegade arvuks võtta 3.  Lasta kuvada ka regressioonmudeli aruanne.
b) Vähendada viitaegade arvu kuni sisse jäävad vaid statistiliselt olulised viitajad.
c) Kas trend on statistiliselt oluline?
d) Hinnata ilma trendita, konstandiga mudelit, võttes algseks viitaegade arvuks jälle 3 ning vajadusel vähendada viitaegade arvu. Kas konstant on statistiliselt oluline?
e) Hinnata ilma konstandita mudelit, võttes algseks viitaegade arvuks jälle 3 ning vajadusel vähendada viitaegade arvu.
Vaadata teststatistikut Z(t). Panna tähele, et see on positiivne. Ühikjuure testi korral aga teststatistik ei  tohi olla positiivne. Dickey-Fuller testi korral on testitavaks mudeliks

	
Teststatistik




kus  on standardviga. Kui Z>0, siis järelikult δ>0 ja  ρ>1. Sellisel juhul protsess  on plahvatuslik. Seda aga diagramm ei näidanud ja plahvatuslikke protsesse majandusaegridade korral üldiselt ei esine. Seega, kui teststatistik on positiivne, on midagi korrast ära. 
Probleem on järgmine. Kuigi trendiga mudelis trend polnud statistiliselt oluline, siis diagrammilt oli näha, et trend oli, aga muutus. Seepärast ei õnnestu vastavas regressioonmudelis trendi statistilist olulisust näidata, standardviga väga suur. Kui visuaalselt on trend näha, on soovitav lähtuda ikka trendiga mudelist.
f) Vaadata trendiga mudeli (kus kõik viitajad olulised) teststatistikut: see on negatiivne, nagu peab olema.  Vaadata olulisuse tõenäosust p ja võtta vastu otsus.
 Kuna p=0,6586>0,05, võtta vastu H0: ühikjuur esineb.

6) Trendi eemaldamiseks võtta aegreast 1. järku diferentsid. Diferentside leidmiseks tuleb kasutada diferentsimise operaatorit D, millele järgneb punkt. Käsu generate asemel võib kasutada ka sama käsu lühemat varianti gen
gen d_THHI=D.THHI

7) Tutvuda diferentside aegrea diagrammiga.
8) Testida Dickey-Fuller testiga, kas diferentside aegrida on statsionaarne.
Sobib konstandiga mudel, viitaegade arv 0. Teststatistik Z=-6,679, p=0, võtta vastu H1, ühikjuurt ei ole.
9) ARMA modelleerimiseks tuleb aegrea mudel identifitseerida, selleks uurida diferentside aegrea korrelogramme. 
a) Autokorrelatsioonifunktsiooni ACF korrelogramm
Graphics > Time-series graphs > Correlogram(ac)
Et see diagramm jääks alles, kui soovime uut tekitada, nimetame Edit menüüst ümber, näiteks ac.
b) Osalise autokorrelatsiooni funktsiooni PACF korrelogramm
Graphics > Time-series graphs > Partial Correlogram(pac)
Korrelogramme võrreldes võiks olla tegemist AR(1) mudeliga, sest AC korrelogrammil on järjest 2 nullist erinevat väärtust.

10) Hinnata vastava mudeli parameetreid ja kontrollida, kas need on statistiliselt olulised.
Statistics > Time series > ARIMA and ARMAX models
ARMA specification	Autoregressive order 	1
11) Tuleb testida, kas vealiikmed moodustavad valge müra. Selleks tuleb vealiikmed salvestada ja siis vaadata nende Q-statistikut ja selle olulisuse tõenäosust.
a) Vealiikmete salvestamiseks 
Statistics > Postestimation > Predictions > Means from the differenced and ….   Launch
Vealiikmete salvestamiseks anda neile nimi res ja valida Residuals or predicted innovations 

b) Testida, kas salvestatud jäägid on valge müra (autokorrelatsioon puudub)
Statistics > Time-series >Graphs > Autocorrelation & partial autocorrelations
Variable	res
	Uurida veergu Prob>Q, kus on Q statistiku olulisuse tõenäosus. Viitajani 23 on valge müra. Pikema perioodi korral ka viitajani 39 on valge müra. Kuna soovime teha prognoosi lühikese aja peale, rahuldume sellega.
12) Testida, kas jäägid alluvad normaaljaotusele, kasutades Shapiro-Wilk normaaljaotuse testi
Statistics>Summaries, tables and tests > Distributional plots and tests> Shapiro-Wilk normality test.
Kuna p=0,77616>0,05, võtame vastu H0, jäägid alluvad normaaljaotusele.
13) THHI prognoos valimi sees ja valimist välja 12 kuud.
a) Hinnata mudelit ARIMA(1,1,0) aegrea taseme THHI jaoks.
b) Valimist välja prognoosimiseks on vaja lisada andmebaasi väärtusi. Kui soovime prognoosida 12 kuud edasi, tuleb lisada 12 väärtust. Lihtne vaatluste lisamine ei tekita ajamuutujale month uusi väärtusi. Tuleb kasutada spetsiaalset käsku.
[bookmark: _Hlk153486368]Statistics > Time-series >Setup and utilities>Add observations to time-series dataset
Lisada 12 väärtust.
c) Prognoositud väärtuste leidmine.
Statistics > Postestimation > Predictions > Means from the differenced and ….   Launch
Prognoositud väärtuste salvestamiseks anda neile nimi hat_THHI ja valime 
Values for mean equation in y – the undifferenced series
Aknas Prediction after estimation valida lehel Options
 Switch to dynamic predictions at time	tm(2018m1)
 Tähistus tm tähendab, et aeg on kuudes.
d) Tutvuda andmetabeliga ja veenduda, et on lisatud prognoositud väärtused kuni 2018m12
e) Koostada diagramm, kus on THHI tegelikud väärtused ja prognoositud väärtused.

14) Prognoosimisvõime näitajate arvutust programmis Stata pole. Arvutame keskmise suhtelise absoluutvea valemi järgi


a) Algul leida suhtelised vead. Käsuaknasse
gen suht_viga=abs(THHI - hat_THHI)/ THHI
b) Nüüd leida suhteliste vigade keskmine. Käsuaknasse
mean suht_viga

	Tulemuseks on 0,003 ehk 0,3%.


VASTUSED
Kõik tulemused on vastavates logifailides.
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